Accent LED changes state with blade color

Still trying to get rid of S3 meddling, just a few things left until total victory.

Been trying to duplicate the S3 power button LED function: When the board is on/awake, the LED should be on. It goes to sleep after X seconds. It also turns on when plugged into USB.

EDIT FOR CLARITY: It’s a single color LED.

One would figure the LED is connected to a blade style. I’ve tried quite a few variations of a second blade style, but it’s almost like it doesn’t matter so long as there is something there that doesn’t error. With every variation, the LED is reacting to the blade color when changing blade colors via edit mode. On certain colors it’s full bright, half, or off. This is duplicatable. Meaning, spinning the colors, the same colors either do or do not influence the LED. It still always turns on when USB powered.

Orig S3 config (Edited out long list of blade styles. Not sure why no comma after last style)

New Proffie 6.8 config (Trying second blade style ideas using Fett style editor, proof of concept, duplicated top config more or less, everything else works as designed)

Even tried using S3 2nd blade style:


Running out of ideas. I assumed it was single pixel LED but maybe it ISN’T a second blade (#define NUM_BLADES 2) and the second blade is just a place holder for something? Somehow connected to a power lead on board?

Ran Windiff on S3 Proffie and Genuine Proffie. Line by line, nothing jumped out as “Hey idiot, I make a huge difference”

I’m confused.
What is it that isn’t working?

If you use just WHITE as your style, then edit mode cannot change the color.
If you can still change the color, then the upload must not have worked or something.

I’m sorry I should have specified.

The power button LED is single color. It does not change colors. Just turns on or off. I chose ‘white’ because I had to choose something in the RGB drop down.

What isn’t working is the LED should just stay ON when there is power to the board, regardless of whatever style or color or anything else.

The LED should do nothing, but it’s reacting to the blade color choice and I have no idea why.

This style ought to do that:


It might also be worth trying a style like:


This should make the LED pulse, if it doesn’t there is something weird going on. (Like, maybe the code isn’t uploading?)

This is exactly what Sabertrio provides in all of their presets for that second blade style (the switch’s LED), so I’m not sure how anything is different.

And that’s why I tried it


already, with the same result.

It doesn’t matter what I put for the second style. As soon as I load genuine Proffie, the button LED starts to do it’s own thing when selecting colors through the edit menu - on/off/dim.

Loading S3 Proffie back on, the LED functions as intended. On when board is on/awake, off when board is off/asleep.

But that’s insane
Maybe it’s time to check how it’s wired instead of looking at the code?

There’s no differences in their OS that pertain to this simple thing.
If you’re loading the same exact config file, with the same BladeConfig, that doesn’t make sense.
Are you sure you don’t have #define KEEP_SAVEFILES_WHEN_PROGRAMMING active?

That’s what I’m saying. Makes zero sense.

Let’s say it isn’t config file dependant.

What other files control LED power distribution?

There is that “Shared power pin” define, but not sure where to trace that.

When I did Windiff on the whole proffie folder, there were some differences, nothing major, and like I said before, nothing stood out.


is not active.

So when you use edit mode to change colors, and the LED reacts to it, are you changing colors on the main blade or the second blade?

I am only changing colors on the main blade. It’s the only illuminated thing that has the ability to change colors. The second blade (power button LED) only turns on and off. It shouldn’t do anything but turn on when the board is on, or off when the board is off. I say board and not blade. It’s totally main blade independent.

The only reason for that light is to tell the user “your board is awake” and so you can find the button in the dark. It’s not designed to or supposed to have any other function.

Maybe the hooked up the LED to data1?
If so it would light up whenever the main blade is active, and it would change color a bit depending on the color of the main blade. (More ones would make it brighter.)

Wait you’re saying it’s going on and off… in edit mode. Does the main blade do the same thing?
Doesn’t edit mode blink all the blades one at a time so you can choose one to edit?
Are you hitting enter to choose a blade before editing it? SOunds like you’re just cycling through choices of blades to edit and you need to go one level deeper in the menu by actually choosing the blinking blade.
I have never used edit mode so I’m speaking from what i remember the blade edit menu to be like.

The Switch LED should be solid white when NOT in edit mode and you’re igniting and retracting the main blade (normal use, not edit mode)

The thing is, with the S3 Proffie, it is always lit, regardless of what the blade is doing. Main blade can be on, off, any color. The power button LED should be on steady until the saber goes to sleep or cutoff power.

It MUST be in one of the little tweaks they made somewhere. I mean, it’s a LED with a simple function: when the board has power, turn on. Can’t be that many places where that can be modified.

Yes it’s going on and off and half dim in color edit mode depending on the color. But then the power LED remains in that on or off or dim state based upon what color I select.

Let’s give this for instance.

Turn board on from kill switch, LED is on. Blade ignites green. LED still on. All good.

But now I want the blade red. Go into color edit, twist the blade until red. However, while I’m passing all the other colors, the power LED is changing from on to off to half. Red happens to be one color that it always seems to be off

So, confirm red main blade color selection. The power LED is still off.

Retract blade. LED still off. Ignite blade, LED still off.

I want a different color so go into color edit, twist back to let’s say white. Turning the hilt again, scrolling through the main blade colors, the power button LED changes illumination on/off/dim. Confirm white. LED is on. Retract blade, LED is still on. Ignite white blade, LED is still on.

Maybe a video would be better?

A video would probably be good.

and post your config file?
and clarify which version ProffieOS you’re seeing this with, and what version does S3 provide (base)

Hey guys, wanted to chime in as I was able to replicate this occurrence. I replaced the default preconfig on my S3 Proffie-equipped Vektra from their default 3.02 code and switched to using Fett’s configuration, and my illuminated switch either didn’t light up, or was dim on specific colors in the edit color mode. White, or some color that is high in all three RGB values, seemed to be the only consistent one where it was brightly lit.

I reckon what’s happening is the fact that your Proffie code uses saber_fett263_buttons.h for CONFIG_PRO instead of saber_sabertrio_buttons.h as that’s the one thing that stands out between the two configs you posted. Did you try changing your code to use saber_sabertrio_buttons.h instead to see if the switch remains illuminated regardless of the color of your blade during edit colors?

Configs were in first post. Pastebin links.
S3 Proffie: 6.7
Genuine Proffie: 6.7/ 6.8
But that’s irrelevant now.

THANK YOU for proving it wasn’t just me having this issue. It’s a relief.

You beat me to it. The button configs were my next angle of attack after ruling out config typos
…and it works.

Using saber_sabertrio_buttons.h instead of saber_fett263_buttons.h the LED stays lit as it should during all saber operations. On/Off/color change, etc.

S3 button config:

Windiff between the two button files ( saber_sabertrio_buttons.h and saber_fett263_buttons.h) showed a lot of differences. It’s ALL red and yellow. I’ll try to find the offending code but this isn’t totally my bag. 23 years of IT experience though, I’ll try.

By the way, I’m only doing this Anti-S3 crusade to help the other guy, not necessarily me. I see everywhere how people with Sabertrio sabers are more or less SOL (s…t out of luck) when it comes to diagnosing Proffie issues. I was one of them. Fortunately I’m almost there to de-meddling the files and releasing S3 customers from their programming prison. Thank you ALL for being tolerant and doing what you can to assist. Proffie is great as-is. No changes needed. S3 needs to simply STOP messing up a good thing. All the work you fine folks so is selfless and amazing. People like you are so rare, makes my heart rejoice.

1 Like

It probably is due to how Fett263’s color change works compared to S3’s kyber dial. Fett can correct me if I’m wrong, but I think what his color change does is that it switches between the different preset colors (i.e Ice Blue, Dodger Blue, Moccasin) but it affects the values of all the StylePtrs until you exit the color change mode, in which case it reverts to the second StylePtr of your config.

S3’s Kyber Dial method on the other hand simply adjusts the RGB values of the first StylePtr while leaving the 2nd StylePtr untouched, hence why the illumination switch stays the same throughout the whole process. I don’t think it’s necessarily meddling, it’s just a different way to achieve the same goal. Also hearing that S3 Proffie users aren’t getting support seems to be quite contrary to what I generally hear about them online.