About playing multiple tracks for one font

Hi all,

I’m having trouble playing more than one default track per font. I’m using the saber_fett263_buttons prop but I can’t go to the next or previous or random track by using the controls as described. I have the tracks in the font folder as instructed by the prompt but it ill only play the default track. Do I need to put the names of all tracks in the config? For example I have this:

{ “He-man”, “tracks/He-man.wav”,//27–

but maybe I should put more than one track there like this?:

{ “He-man”, “tracks/He-man.wav,He-man2”,//27–

Any thoughts on how I can play multiple tracks on the fly would be most appreciated. Thanks in advance!

The “tracks” folder should be either in the font or common, not the root. If you have tracks you want to use specific to the font put them in “font/tracks”, if you have tracks you want to share across fonts put them in “common/tracks”

See information here:

You also need “common” set up in your preset, refer to Set Up Instructions for my prop, “;common” is required.

I already have the tracks folder in the font folder but I’ll try it with the common folder too. Thanks!

Make sure the tracks are formatted correctly, they need to be 44khz, 16-bit mono PCM wav files.

You’re missing the “;common” in your preset which is required for the player controls.

Okay, so I tested the tracks individually to make sure they work and they do, but I still can’t get the saber to switch tracks. I tried a few things but no luck yet so clearly I’m doing something wrong. Here is the preset in my config I’m currently testing with:

{“Lumos”, “tracks/Lumos.wav”,//9–

Here is how my SD card is currently set up:

SD root:
tracks - Lumos.wav
- Patronus.wav
font - Lumos.wav
- Patronus.wav
common - Lumos.wav
- Patronus.wav

I know it looks wrong so if you could help point me in the right direction that would be awesome, thanks!

I just saw it and it might look weird, so I have a tracks and the Lumos folder on the SD root, andI have a font and a common folder in the Lumos folder. I put the wav files in the tracks, font, and common folder if that clarifies my setup. Thanks again.

You’re not reading what I wrote and/or the links I provided.

Your preset should look like this:

{ "Lumos;common", "Lumos/tracks/Lumos.wav",

If you just have a “tracks” folder in the root of the SD it is not seen by Track Player. Track Player (as the page I linked says) looks for the “font/tracks/” or “common/tracks/” folders. If you just have “/tracks” it is not seen.

Go back a few replies ago and read through the POD page for Track Player and the Required Set Up for my prop and correct your SD and config accordingly and it will work :wink:

Okay, yeah I had the common/tracks folder on my root previously but it didn’t work probably because my preset was wrong, so I went and reverted it back to just a tracks folder. I’ll try this and let you know how it goes. Thank you!

It worked! You are a gentleman and a scholar! Thank you and happy new year! =)

You’re welcome, Happy New Year!