Stab is causing a loss of audio or a power cycle on the v3.9 board

I just finished installing my second v3.9 and it has an identical issue that my first 3.9 install has. About half the time when I do a stab it will either cut part of the audio, usually the hum or swings, or it will just power cycle and restart. I assumed I did something wrong with the first where the stab motion was causing something to short, even though it was happening with some extremely light stabs. Also, as far as I can tell, only stab and melt seems to trigger this. Everything else works fine in both cases.
I have tried OS 6.9, 7.7 and 7.8. I cannot get it to trigger in the serial monitor (I broke a USB adapter and almost my chassis trying). I just tried again with the new install and it too will not trigger in the serial monitor. I have checked all visible connections and nothing is suspect. I also tried in WebUsb with no luck. The battery is quite secure in both cases. Both have springs tightly holding the battery in place. Nothing seems out of the ordinary, except the stabs.
What else can I do to troubleshoot this?

Is your battery hard-wired or removable?

Edit: I see that it is removable…

My suspicion is that the stabs somehow causes the power to go away for a very short time. That might also explain why doesn’t happen when USB is connected, since the USB cable would provide power during that time.

One other thing I forgot to mention is that the only other difference, besides the v3 board, between these two builds and the all the others is I used the new Shadowfoil Props 24 pixel pcb. Is it possible that those could be a factor?

I have no idea what that is.
I guess it’s a pogo pin PCB?
Maybe it’s causing a short somehow?

It’s this:

I normally use the Shtok v3, but this has 8 more pixels and more is cooler. But not if it is causing a problem.

Is it possible the stab is causing a short, maybe something exposed and the blade compressing in from the stab is causing a wire or pin to short?

That occurred to me too. One the sabers has a removable chassis and I tried applying different amounts of pressure and some taps on the desk to the pcb, trying to mimic a stab. Not scientific by any means, but no luck. It seems to need a blade. It’s just odd that the same thing has happened twice. The first time I assumed it was something I did, but now I’m not so sure. I just don’t know how to test it.

Maybe the short is in the PCB pins, test for continuity between different pins, like + to -, + to data, data to -

Same blade or different blade?
(Maybe the problem is the blade?)

I will try that when I get home. Am I incorrect in assuming that the short would need to be actively happening to register anything out of the ordinary?

I have tried 3 or 4 different blades.

Is it possible the + and - are somehow reversed in the connector and the blade creates the short?

Or maybe a pin on the connector is slightly out of line and the blade coming into contact creates the short?

Or maybe when you stab the blade it shifts just enough to bridge a + pin and - pin?

Without re-reading the first replies is the battery removable and a button top? I’ve had cases where it took a stab or a melt to repeat the issue of a battery being just loose enough o temporarily disconnect. All it took to fix was needle nose pliers and bending the negative tab out enough to retain tension.

Possible I switched the + and - wires on the connector? Highly unlikely.

A pin out of line? On the first, I would say definitely not. On the other, I would leave room for the possibility, since I took a stab at designing the pcb holder. So yeah, I could have messed up, though it looks pretty good and I would be the first to admit if it was wonky. The first one is a Jimmy Saber Junk design and every thing looks even and clean. Plus there is no room for movement in the hilt, everything is snug.

Blade shift? Same as above. I just tried a little test where I took a very short blade (8 in or so), that was nice and snug, so there was no wobble whatsoever and tried it with both. Both still did the thing, even with light taps and fully supporting the blade.

I did the continuity test on the removable chassis and got:
pos to neg = 4.04
pos to data = 3.69
neg to data = .30

edit: didn’t realize it made the symbols bullet points ¯_(ツ)_/¯

Removable button top and tried multiple. And they are both secure. The battery being loose was my first thought, as I have had that happen before.

Is your spring side (negative) on the blade end of the battery?
Almost guaranteed it’s just compressing with the impact and the positive is pulling away from the contact…
To test, push the battery into the spring end fully, cram a small ball of tin foil in the positive between the button top and contact. Try.

One is one way, one is the other. I tried to get it to replicate the issue just trying to move the battery. No dice.

I just found out though that it does not need the blade. All I need to do is lightly tap the emitter against a wall. Happened with both sabers. Their symptoms are absolutely identical and they are very different sabers.

May seem like a silly question, but does it do it in other directions? like tapping the pommel end or laterally on the side of the hilt?

Could you clarify what that means? Did you cram tin foil in pushing the battery back against a fully compressed spring?
Or try temporarily supplying voltage to the board directly via the battery pads?

My vote is still something with the battery compartment(s). Seems unlikely I know, but otherwise what are we looking at? A faulty motion chip/gyro that doesn’t like forward thrust and impact?

Actually, yes. I just did the same wall tap test, but with the pommel and both responded the same. I have clashed them to hell in all other directions though with no issues.

All I did was try to slide the battery while it was on with my finger to see how much force is needed to make it lose connection and see if I could get it replicate the audio loss problem. While I can obviously kill the power with enough force, I have not been able to get the sound to stop, which is the main occurrence. And the taps I am giving these things are not enough to move either battery, I am 100% on that. Battery connection issues were my first thought and I cannot get them to fail in any other fashion. I have dealt with and fixed several loose battery situations, I really think this is something else. I really wish this would trigger in the serial monitor so I could give you guys some real data. I just tried again. Must’ve done 50+ stabs. :expressionless: