Spontaneous Self-Ignition Of The Blade After IDLE OFF

Hello there!
I just finished my first install and it mostly works great.
But I have a strange behaviour that my blade ignites itself a while after it IDLEd OFF.

What i use is ProffieOS 5.9 with sa22c’s button prop file with SWING_ON, TWIST_ON and TWIST_OFF.

I analyzed it with the serial monitor.

It seems to register a SWING even though it lies flat on the table and there is no impact or anything that might shake the board:

I tried to find something about it on the Proffie Support Group on FB and on a topic Fernando mentioned it might be a motion chip reboot.

So I disabled the motion effects and analyzed it again.
Board turns off most of my components after my defined 5 minutes of IDLE OFF TIME.
About 10mins after that it registers a “Motion disable”.

So my guess is, Fernandos hunch might be correct.

Is there something I need to configure for the motion chip not to reboot? Any Ideas how to fix this? I mean I could not use SWING_ON but I really much would like to have it in there.

Here is my config file:

Thanks
kaQnub

1 Like

So there are multiple things that could be happening here.
Some of which can be easily worked around in ProffieOS 5.9, and some which have fixes in ProffieOS 6.x.

So, one thing that might help is to adjust the 20000 here to something much bigger:

If that doesn’t help, then maybe upgrading to ProffieOS V6 (from github) might be worth a try.

Hi @profezzorn, thanks for the reply. Upgrading to ProffieOS6 is something I definitely will do down the road.

Do I read that correctly, that the right part of the OR is checking if the last motion request was not older than 20 seconds?

With the help of @NoSloppy I tried setting the MOTION_TIMEOUT manually to the same 5mins my IDLE_OFF_TIME is set to.
This workaround led to the blade not igniting again when the motion chip together with the rest turns off.

Maybe I’ll try setting MOTION_TIMEOUT manually to the 15 minutes it is by default, to see if this is an issue with the value or rather when it is set.

1 Like

are you saying that it’s available on github or it will be?

@Afrojedi Max, click the green Code button and choose download zip.

Okay, final feedback.
As I mentioned it stopped igniting itself when I set MOTION_TIMEOUT manually.
After having it initially at the same value as my IDLE_OFF_TIME (5mins) I tried setting it manually to the 15mins it would be set by default.
Even this worked without self-ignition.

As my last step I commented my MOTION_TIMEOUT out to see, if it would ignite again, being basically back to square one. Well, it didn’t. Which is great but confusing. Matter solved I guess.

Cheers,
kaQnub

1 Like