Running 3 blades (2 main, 1 mini) on a SaberBay DarkMatter issue

Ordered a single neopixel since I needed one anyways and thought I had one already.

But the second test bore fruit! Bridging middle sections LED6 to ground made it run the off color! Since the board usually does that anyways after a reset, I turned it on and off multiple times (usually what kills the off color) and it still worked as the preset demanded! I then removed the battery, put the bridge wire from LED6 to 4,5 (furthest PCB). Middle section stopped it’s off mode. However, furthest PCB still doesn’t light a blade, only its own LEDs.

If you LED 4/5/6, then you need to do two things:

  1. update your config to have LED4,5,6 as the power pins for the second AND third blade.
  2. add #define SHARED_POWER_PINS to your config.

Bridging isn’t really the right solution though.
If LED6 is bad, you should probably just move the wire to LED1. (and update the configuration accordingly.)

The PCB that doesn’t light a blade is almost certainly a problem on/in the pogo pin PCB. In AC mode, do you measure data coming from the middle pin?

Well this is odd. I moved the wire to LED1 and updated the configuration to bladepowerpin1. It went to the same behavior as it was in LED6 (turns on when saber is on but once saber turns off, off color doesn’t kick in). I’ll try the 4,5,6 bridge tomorrow.

In AC mode I do measure 0.02 to 0.4 out of the middle pin. I bought another just in case that’s on the way.

Bridged 4,5,6. Middle section continues to work on off mode as it should.

Put in a new PCB on the far side. Still not lighting up the blade and only lighting the LED’s. PCB is getting 3.7V (albeit without blade attached since that’d be hard to measure with the way the chassis and hilt is) and data pin showing around 0.4-1V when on.

Could it be a power issue in that v2.2 can’t send enough power to light up 2 blades and a mini blade in the middle?

No, that should not be the problem.

Maybe it’s time to make a video of the issues? Maybe that way someone will spot something?

Hmm ok. That was the only other thing someone else had come up with on another place (though I’m running a 20awg for all power). I’m gonna send it off to a fellow installer to see if he can see anything up close. Hopefully that resolves it and he finds out if it was anything hardware-wise. If not, I’ll make that video.