Recently got kylo saber from zia sabers

I tried connecting it to my computer and tried the bootloader with the two buttons but literally nothing happens on my computer, is it possible that my top USB ports on my case I can’t use or the cord I’m using doesn’t like the saber? Also separate issue I pulled out the chassis to far and the connectors too the crossguard came out of the 2 sides I don’t know how to access them to get to it to reconnect them.

Why are you trying to get to the bootloader? It is generally not required.
The most common cause of USB communication problems is the cable.
Make sure that what you have isn’t a charge-only cable, and even if it isn’t, I would suggest trying a different one…

For this I suggest asking the seller.
People on this forum generally have no special knowledge of how a particular product is put together and wired, especially since many of us build our own.
However, if you’d like our opinion, post pictures and we’ll make some educated guesses. :slight_smile:

Trying to access the board to upload soundfonts, and change the blade profiles because all of them came with unstable which I think is ridiculous. I don’t have anything that I can pull the SD card out with it’s pretty snug in there. But as for the wires I’ll see if I can get some pics


There is the inside

You don’t need bootloader mode for that though.
What directions are you following?
(Maybe try these ones: ProffieOS Documentation: Proffieboard Setup)

If you have USB connectivity issues, the port won’t show up in Arduino → Tools → Port, but once it does, all you need to do is push “upload”. (With a properly set up config file of course.)

Is that from the blade side? (Or the chassis side)

It seems like the connectors should be under the pogos, not on top, right?

The port is greyed out and nothing happens at all when I plug my saber into my computer

That’s the top view where the blade goes those wires go inside the crossguard piece but I have no way to access inside that small space to reconnect them to the prongs in the side blades

There is a multitude of possible reasons for this, but 9 times out of 10, it turns out to be because of the usb cable.

When you unscrew the silver parts on the side, can you take the pogo pin piece off? (That way you should be able to re-connect, and then push everything back in again.)

alright so update good news i got the saber to connect with another saber but now i messed that up somehow and will have to bootload it because it says unrecognized usb and audino wont recognize it either, but also i got the prong things to come out so hopefully if i get tweezers ill be able to push it back in and that will be fixed

another usb cord***