Received error message after verifying config file

I am a newbie. Tried to check through threads before posting. Could not find anything related to my issue. I recently had a custom saber build from Powell’s Power Ups. I tried to verify my config file after I had loaded sound fonts on the config file. I did a verify in proffie OS before attempting to load the the new sound fonts onto the SD card. I received this error message attached.
Error message proffie.txt (34.1 KB)
Not sure exactly, but it appears that a few of sound fonts that I changed the blade style is producing the error. And other errors I am not sure what it is. Can I get help with this?

search the file for:
You’re missing a closing bracket > after the Black

It might be that way in a few of your presets so fix them all while you’re at it.
For more specifics, you’d need to post the actual config file, similar to how you did the error.

mysaber_config.h (158.8 KB)
I forgot to post the config file with the error message. 2 of the fonts were missing the > as indicated. fix them. I copied the blade style from fett site for blade style. Not sure what the remaining error are. Any ideas?

When you fix problems, the errors usually change, so please post the error messages you’re getting now.

Error message proffie 2.txt (2.9 KB)
Verified the config file and posted the new error message.

You have two entries in your blades[] array, one seems to be meant for when a blade is in, and the other is when it’s not in. However, you only seem to have one preset array, and it’s called no_blade. The blades[] array says there should be another one called blade, but it is not present in your config file.

Where would that text go in the config?

mysaber_config original.txt (236.3 KB)
Here is the original config file before adding the sound fonts/blade styles.

So why did you remove the blade[] Preset array?
The original file is much longer since it has two Preset arrays.

I am looking at the original and the updated one. Where did I remove the blade preset array? All I did was added the new fonts after the Grogu font, but replaced the blade style for 4 sound fonts that were already on the config file.

Line 718 and forward in the original is the part that is missing in your config.

Found it. Thanks!