ProffieOS 7.x pre-alpha discussion

Do you have the latest 7.x from github?
What does your config look like?

Thanks, yeah but It’s not my prop, unless it’s being ignored…
Is the default motion timeout 20 seconds?
That’s what it does using total defaults, default_proffieboard_config.h.

I suspect something else is going on here.
I don’t think anything has changed for motion timeout recently, but it could be something happening because of changes elsewhere I suppose.
Either way, I’ll need more information, like your config file to figure it out.

20 seconds is what happens if nothing calls RequestMotion() to keep it alive.

I’m literally running right out of my Git folder of the current master, using the default_proffieboard_config.h. All I did was change font name to one that exists on this SD card.

oh wait…duh. That’s a terrible test

ok and of course it’s not doing it now. So sorry to waste thread space. I’ll keep an eye out for it happening again. Makes no sense. We can delete these past few posts

This thread is basically obsolete as we’re moving on to alpha testing:

Feel free to continue any discussion in this thread, but most things will be moving on to the alpha thread.

1 Like

Holy crap, yes. The default fonts are missing a lot of sounds to really showcase the fonts. I was just thinking about this the other day actually, when a saw someone showing off a Luke hilt and the manufacturer had just added a Luke boot sound to Smooth Jedi and pretended it was a Luke font.

1 Like

Yes I have the latest t.x from github. Here is the config. I kept one preset only to simplify it. Thank you!


You should see what Serial Monitor says when this happens and then post that.

Nice. Is it worth asking Kyberphonic if his freebies can be included? Or is that crossing a copyright line with Disney/EA?

There are strict guidelines in place that restrict use of any licensed sounds or samples from films, games etc… of which Kyberphonic uses heavily. All fonts hosted on must be created from scratch pretty much.
CODA by Greyscale and LiquidStatic by Blueforce Co (made exclusively for Proffieboard) are just that (and great!), so they’re in there to be included.

That’s understandable.

With serial monitor the problem disappears:

unit = 0 vol = 0.50, Playing GraflexESB2/blst/blst03.wav

channels: 1 rate: 44100 bits: 16

Only 1 blst at a time but on normal operation 2 simultaneous blst sounds. So I thought maybe it’s a physical problem with the button/wiring. So I went back to OS 6.7 and the problem disappeared! Very odd and annoying that it doesn’t show up on serial monitor. Would stick to 6.7 but the phantom clashes are horrible and 7 totally fixed that.

Well it very well may be a physical problem with your button double firing, however that doesn’t have anything to do with serial monitor. That’s just giving you an active event log of what’s occurring. And it shouldn’t be any different whether you’re plugged in or not. You would get an event reported for every button press. So what you’re looking for is how many button presses and then how many blst.wav .

But if that were the case why did reverting back to 6.7 eliminate the double firing issue? It’s worth noting also that this only seems to happen with blst sounds that are quotes not regular blaster effects. I tried several different fonts on 7 and 6.7 and the results are consistent.
6.7: single fire blst for blaster/quote
7: single fire blst for blaster/double for quote
Of course I don’t need to put quotes on blst as they work just fine with force/quote toggle, but I just thought it was a bug worth mentioning, as some fonts come with quotes for blaster.

When did you pull down 7 and are you using my prop? There was a small bug in Multi-Blast that “could” be related, the fix was pushed up yesterday. Try getting a fresh download from github and see if it went away. Although this wouldn’t have acted differently on Serial Monitor and wouldn’t matter what sounds are produced by the wav file, so not 100% sure its actually related.

It could be something with the wav files themselves if the ones with quotes act different than the ones without every time.

Hey that totally fixed it! I pulled it 2 days ago so I guess the multi-blast fix was the cause! Thank you so much! :blush:

Good to hear.

1 Like

The beep code POD page is done:

1 Like