ProffieBoard 2.2 and Windows 11

I have the same problem. Not even sure I’m going to bother.

I’d like to have a windows 11 installation though to be able to help users with windows 11 problems.

1 Like

I’ve held back on upgrading to Windows 11 purely because of compatability concerns for some of my software that I use, now it turns out that this may not have been a bad decision.
Will be interesting to find out what is causing a lot of this and how we work around it.

Finally got Windows 11 installed.
Of course, now it’s bedtime, but I should be able to try some stuff tomorrow.


So I went spelunking in Windows 11 today.
After the upgrade from Windows 10 to Windows 11, Arduino worked just fine, because it remembered the driver I had installed previously.

So I uninstalled that.

Apparently it then found a driver from ST-Micro that I had installed at some point. Unfortunately, that driver did not work with arduino.

So I uninstalled that.

Then I tried the solution described by RORWessels earlier in this thread, which made it use the Microsoft WinUSB driver. That worked with arduino with no problems.

So I uninstalled that.

Then I tried Zadig 2.7, which also worked just fine.

Basically, I had no problems whatsoever with doing all this in Windows 11. I’m not sure if this is because I just installed an update from Microsoft, or if there is something else going on. Maybe my system isn’t configured for maximum security or something? To me this is sort of good news / bad news: On one hand it works just fine, on the other hand, I can’t replicate and help with the problems that others have experienced…


I know this thread is super old but I think this is the exact thing I’m having trouble with if you’re still around and still willing to do a real time chat to walkthrough this it would be greatly appreciated I started a new thread stating my problems but haven’t got to put up my error codes do to being out having to run errands