Proffie Workbench Connection Troubleshooting

Ive tried and followed all instructions to get set to use the workbench. When i plug my saber into the computer it reads but when clicking the usb button on the oage it does nothing. Please help

Did you select one of the “webusb” options in arduino → tools → usb type when you programmed your proffieboard?
What browser are you using?
What OS are you using?
Does the board show up under ports in arduino?

1 Like

I have chosen webusb+serial as suggest by fernando. Im using os6. I will check ports in ardrino.

Im also using Chrome as my browser

Did you program the board after you selected webusb+serial?
If windows; have you checked what driver is in use for the webusb device?

Yes i did an upload after. I am using windows. Which driver should be the proper one

I don’t have a Windows computer available to check right now.
I think it’s supposed to be WinUSB though.

I did the WinUSB Install initially when i got started so my computer would recognize the proffieboard

I checked ports. Does the board only show under ports when its plugged in. Or should it always be available? Cause the ports op is grey under the tools menu in arduino


It will only show under ports when it is plugged in.
Next thing to check is definitely the driver.
Do you see the proffieboard under chrome://usb-internals/ → devices ?

Ive still not been able to connect. Which is odd. I followed all steps and checks. Hownin depth can the workbench edit cause i may not even worry about it being i picked up the editor faster than i expected