Proffie v2.2 blade style displaying issue

Hello,

I recently finished the installation of a KR Thrawn Hunter and I’m having some troubles with my blade style.

I created one in fett263’s styles library but my blade doesn’t display it. I’m able to compile the sketch and upload it on my board but whenever I try to ignite it, it just shows a weird white-green-red color. The blasts and clashes effects don’t show as well, despite the sound working well.

Any help would be greatly appreciated and thank you for the time you took reading this!

#ifdef CONFIG_TOP
#include "proffieboard_config.h"
#define NUM_BLADES 1
#define NUM_BUTTONS 1
#define VOLUME 1900
const unsigned int maxLedsPerStrip = 144;
#define CLASH_THRESHOLD_G 5.0
#define ENABLE_AUDIO
#define ENABLE_MOTION
#define ENABLE_WS2811
#define ENABLE_SD
#define SAVE_STATE
#define ENABLE_ALL_EDIT_OPTIONS
#endif

#ifdef CONFIG_PROP
#include "../props/saber_sa22c_buttons.h"
#endif

#ifdef CONFIG_PRESETS
Preset presets[] = {

  { "CodFlcrm",
"CodFlcrm/tracks/mars.wav",

//StylePtr<InOutHelper<Blast<LocalizedClash<Lockup<TransitionEffect<TransitionEffect<Transitio//nEffect<TransitionEffect<TransitionEffect<AudioFlicker<Rgb<100,100,150>,Rgb<50,50,75>>,Mix<//Bump<Int<32768>,Int<16000>>,AudioFlicker<Rgb<100,100,150>,Rgb<50,50,75>>,RandomPerLE//DFlicker<OrangeRed,White>>,TrConcat<TrWipeIn<600>,Mix<Bump<Int<32768>,Int<16000>>,Au//dioFlicker<Rgb<100,100,150>,Rgb<50,50,75>>,RandomPerLEDFlicker<Orange,White>>,TrWipe<6//00>>,TrInstant,EFFECT_STAB>,White,TrInstant,TrSmoothFade<200>,EFFECT_LOCKUP_BEGIN>,Sty//leFire<Rgb<100,100,150>,White,0,6>,TrInstant,TrSmoothFade<500>,EFFECT_LOCKUP_END>,Mix<//Bump<Int<32768>,Int<10000>>,AudioFlicker<Rgb<100,100,150>,Rgb<50,50,75>>,White>,TrInsta//nt,TrFade<200>,EFFECT_DRAG_BEGIN>,Mix<Bump<Int<32768>,Int<10000>>,AudioFlicker<Rgb<1//00,100,150>,Rgb<50,50,75>>,White>,TrInstant,TrFade<300>,EFFECT_DRAG_END>,Pulsing<Gradie//nt<Rgb<100,100,150>,BrownNoiseFlicker<White,Strobe<Rgb<100,100,150>,White,50,1>,100>>,G//radient<BrownNoiseFlicker<White,Strobe<Rgb<100,100,150>,White,50,1>,100>,Rgb<100,100,15//0>>,3500>,RandomPerLEDFlicker<Rgb<100,100,150>,White>,Bump<Int<16000>,Int<20000>>,Bu//mp<Int<32768>,Int<10000>>>,White>,White>,300,500,Black>>(),

StylePtr<InOutHelper<SimpleClash<Lockup<Blast<Green,White>,AudioFlicker<Blue,White>>,White>,300,500>>(),

"Ahsoka White"
}

};

BladeConfig blades[] =  {  { 0, WS281XBladePtr<123, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(), CONFIGARRAY(presets) }, };

#endif

#ifdef CONFIG_BUTTONS

Button PowerButton(BUTTON_POWER, powerButtonPin, "pow");

#endif

Btw, here is my code the first commented style is what I would like to use and the secod is a simpler one I tried to check if it was displaying properly (I had the same result, no green color just a white-green-red thing)

I’ve had some strange oddities when changing/uploading and when using EDIT mode. I see you have ENABLE_ALL_EDIT_OPTIONS and SAVE_STATE defined, so I assume you’re using Edit mode.

On the SD Card, below all the font folders, there may be some loose ini/pref files. I sometimes have to clear these files when making large changes to the number of fonts or the style code. EDIT mode will re-write them, but you can copy those loose files at the bottom off the SD card to back them up, try deleting them, and then see if that fixes the strangeness with the blade?

Does other styles (with similar colors) display ok?

When you say “white-green-red” do you mean the base is white, the middle is green and the tip is red? (Or something else)

If that’s the case, I would think that the blade is not getting enough power. Does the battery need to be charged maybe?

Maybe post a video?

Well, seems it was related to the battery power which is surprising. I literally booted it in right out of the box, apparently it wasn’t fully charged

We’ve been able to sort out the issue, though I would like to understand what you were talking about with the edit mode. The current code I use is the default_proffieboard_config.h that I modificated to stick to what I want, so I almost didn’t touch the header. Is there a risk that the edit mode mess up with the rest of the code?

You don’t have Edit Mode, sa22c’s prop does not support.