Please Help with this error code, yes I have correct plugin and USB set

https://pastebin.com/embed_js/BFXk9C5g?fbclid=IwAR0r7XmSh2cSIw0XE4hvJr1lcsUCjwxfuKWH2Oj6zDeHTIx3rS6lQbtCvE0

This usually means that there is something wrong with the arduino-proffieboard plugin.
Try re-installing it.

I did and I get same error

You may have to wipe your arduino15 folder to make it re-download it properly.

Also, I see you’re using a nightly arduino build, it’s possible that it’s broken somehow.
If nothing else works, try 1.8.13

well, I gotta new error code

https://pastebin.com/embed_js/a3xQVRN1

That’s a blast from the past.
I used to get that error when I first tried LTO on mac, but I haven’t seen it in a long time.
I’m not sure if it means that the the arduino-proffieboard plugin is still not installed right, or if it means that maybe your $PATH is somehow messed up, or if it’s something else.

I know others have made it work on mac, so it should be possible at least.
I’m going to try it on my work mac and figure out where this file is supposed to be, then we can check if it’s there or not on your system. If it’s not there, then the installation clearly failed somehow.

Ok lmk what to do

Me on Mac. Me see it as an alias pointing to the file directly above it:

/Users/bconner/Library/Arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/lib/gcc/arm-none-eabi/9.3.1 bconner$ ls -al
...................
..................
..............
-rw-r--r--   1 bconner  staff     46088 May 21  2020 libgcov.a
-rwxr-xr-x   1 bconner  staff    100656 May 21  2020 liblto_plugin.0.so
lrwxr-xr-x   1 bconner  staff        18 Jan 15 19:46 liblto_plugin.so -> liblto_plugin.0.so
-rwxr-xr-x   1 bconner  staff    983756 May 21  2020 lto-wrapper
-rwxr-xr-x   1 bconner  staff  19720172 May 21  2020 lto1

Whats that mean

what should I do
other than deleting and reinstalling everything bc Ive done that many times already it didn’t help

okok update

  1. Sketch uses 245128 bytes (99%) of program storage space. Maximum is 245760 bytes.

  2. 10

  3. 9

  4. 8

  5. 7

  6. 6

  7. 5

  8. 4

  9. 3

  10. 2

  11. 1

  12. FAIL

How did you fix the previous problem?
Did you select the right port in arduino->tools->port?

I think I did somehow, what port should I have set

Usually one port says “(Proffieboard)” after it.
If you don’t see that you might need to do a BOOT+RESET to put the board in bootloader mode.

2 Likes

I love you

thx!!!