New TXQ Saber not detected

I own 4 LGT Proffie 2.2 sabers. With the 1st 3, When I plugged them into my Windows 10 PC, they were immediately recognized, both in File Explorer and the “Eject Device” in the lower right task bar. I had no issues adding sound fonts onto those cores and could access them on the Easy ProffieOS site to add and change blade styles many, many times for all 3. About a year or so ago, I purchased the 4th LGT saber that, when I plugged it in to my PC, a message came up saying that the Proffie Board was being configured and then said it was configured properly, but then it could not be “seen” in File Explorer or the “Eject Device,” and when I tried to make saber style additions, it was also not seen by the Easy ProffieOS site. At that time, I did research online and there were stories about a bad chip on the Proffie Board. After working with that seller, this turned out to not be the case. They sent that saber to their programmer and when I received it back, it worked perfectly - recognized by my PC and Easy ProffieOS site and able to make changes to blade styles ever since.

I just purchased a saber made by TXQ Sabers. I believe it’s programmed with Proffie 7.*. When I plugged in the saber to my Windows 10 PC (the same PC that my other LGT sabers currently work on with no problems), it just did the same thing that I described above…Windows message popped up saying it found and configured the Proffie Board, but it is not “seen” in File Explorer, Eject Devise, or the Easy ProffieOS site. Since the SD Card has to be “ejected”/unmounted from the board for the EasyProffieOS site to work, I removed the SD card from the saber and connecetd to the site. When i clicked on the USB link, the message “Non WebUSB Interface Found” came up and i could not access Proffie from the site. This appears to be an issue with the Proffie OS program on this board and not a hardware issue, and common enough that several people have posted about it online over the past year or so, but I have not been able to find a solution posted. Obviously, there is one as the tech at the LGT seller was able to fix it - can you tell me your thoughts on why this is occurring, and how I can fix it? Do I have to reinstall the config file? And, if so, how do I do this, since the board is currently “invisible” to my PC in it’s current state?

Thank you for your thoughts and help on this, and let me know if you need any further info or screen shots to demonstrate what I am talking about.

This just means that it wasn’t set up with Mass Storage and without WebUSB enabled under USB Type.

When uploading to your board, in Arduino > Tools > select USB Type: “Serial + WebUSB”

See here:

Thank you for the response. I seem to recall the last time I went through this with the LGT saber, I tried re-loading the config file, making sure to account for the Mass Storage and WebUSB you mention here, and i got error messages when i tried to upload the config and it wouldn’t go through. At that time, i had done that 1 or 2 times before on another saber successfully, and I followed a step-by-step tutorial from Absolute Sabers. Will give it a go on this one and report back if it was successful. If not, I’ll make note of the error message(s) I get. Thanks again for the response and the link!

I just got a reply from the dealer I bought the saber from, and they sent me the config file. In a few areas, there are Chinese symbols. When I re-load the config, what will happen if I delete the Chinese characters?:

#ifdef CONFIG_PRESETS
Preset presets = { //2022.7.25增加为23套音效

{ “Ani-Mation”, “tracks/BattleOfHeros.wav”, //1
StylePtr<Layers<AudioFlicker<RotateColorsX<Variation,Blue>,RotateColorsX<Variation,Rgb<0,0,128>>>,AlphaL<AudioFlickerL<RotateColorsX<Variation,Blue>>,Scale<IsLessThan<SwingSpeed<600>,Int<13600>>,Scale<SwingSpeed<600>,Int<-19300>,Int<32768>>,Int<0>>>,LockupTrL<Layers<AlphaL<AudioFlickerL,Bump<Scale<BladeAngle<>,Scale<BladeAngle<0,16000>,Int<10000>,Int<30000>>,Int<10000>>,Scale<SwingSpeed<100>,Int<14000>,Int<18000>>>>,AlphaL<White,Bump<Scale<BladeAngle<>,Scale<BladeAngle<0,16000>,Int<10000>,Int<30000>>,Int<10000>>,Int<10000>>>>,TrConcat<TrInstant,White,TrFade<400>>,TrConcat<TrInstant,White,TrFade<400>>,SaberBase::LOCKUP_NORMAL>,ResponsiveLightningBlockL<Strobe<White,AudioFlicker<White,Blue>,50,1>,TrConcat<TrInstant,AlphaL<White,Bump<Int<12000>,Int<18000>>>,TrFade<200>>,TrConcat<TrInstant,HumpFlickerL<AlphaL<White,Int<16000>>,30>,TrSmoothFade<600>>>,ResponsiveStabL<Red,TrWipeIn<600>,TrWipe<600>>,ResponsiveBlastL<White,Int<400>,Scale<SwingSpeed<200>,Int<100>,Int<400>>,Int<400>>,SimpleClashL,LockupTrL<AlphaL<BrownNoiseFlickerL<White,Int<300>>,SmoothStep<Int<30000>,Int<5000>>>,TrWipeIn<400>,TrFade<300>,SaberBase::LOCKUP_DRAG>,LockupTrL<AlphaL<Mix<TwistAngle<>,Red,Orange>,SmoothStep<Int<28000>,Int<5000>>>,TrWipeIn<600>,TrFade<300>,SaberBase::LOCKUP_MELT>,InOutTrL<TrWipe<300>,TrWipeIn<500>,Black>>>()

“TeenysSF”, “tracks/mercury.wav”,//23 —2022.7.25添加
StylePtr<InOutHelper<EASYBLADE(OnSpark, WHITE), 300, 800> >()
},

{ "BOBAS1E5MANDO ", “tracks/mercury.wav”,//24 —2022.8.11添加 白色
StylePtr<InOutHelper<EASYBLADE(OnSpark, WHITE), 300, 800> >()
},

{ “FALLENORDERCALBUNDLE”, “tracks/uranus.wav”,//23 —2022.8.11添加 冰蓝
StylePtr<InOutHelper<EASYBLADE(OnSpark, WHITE), 300, 800> >()

Absolutely nothing. They’re proceeded by // which means they are a “comment” and are irrelevant for the code.