New SD Card not detected

SanDisk 32gb (red/grey), fresh out the box. Formatted correctly and all files pasted from the old card. Proffieboard does not detect it. I know this brand/model works because I use it on another saber. I can confirm that the card from the other saber does work on both. Any suggestions?

How did you format it it?
Did you use the sd association formatter, or something else?

Yes i used the sd format application. Tried 3 cards, all brand new. Tried both quick and full format, nothing worked. All 3 cards were SanDisk Ultra 32gb

That is quite strange.
(Just to be clear; you used the application from here: SD Memory Card Formatter | SD Association ?)

I think we need to check if the SD card is FAT32 and MBR (not GPT).
Are you on mac or windows?

Yes that is the one i used. All formatted fat32. I tried 16gb partition and it did not work as well. I’m on windows. I’ve tried my laptop and desktop

Wonder what’s going on then… Seems like there has to be some incompatible change in the cards themselves? (Or has the SD formatter tool changed recently?)
I don’t suppose you have some disk imaging tool you could use to copy the blocks from the sd card to a file? (Then zip the file and attach so I can take a look at it.)

If you could link me a tool to do so, i could try that when i get home. I joined the Facebook support page and there has been reports of the same issue. They are also using the same card as mine. Found a guy who also had 3 of them that didnt work

Well, if nothing else works, I might have to get my hands on some of these cards to see if I can figure out why they won’t work. I mean, it sounds like you’re using the right tools and everything, so it should work.

Getting a disk image might be a waste of time, but here is a tool that can do it on windows:

My post was hidden and flagged for moderator attention. I don’t know what i did wrong. I did attach a screenshot from Facebook but deleted that now. Was that not allowed?

Using screenshots when cut-n-paste will work is not allowed on this forum. It is hard to read, both for humans and search engines, and it takes more space on my server.

Hey again, I got some information. I tried a 128gb san disk ultra. Formatted fat32 and it works perfectly fine. I noticed that the SanDisk cards that did work are “Made in China” while the 3 cards that did not work are “Made in Taiwan”

1 Like