New 89Sabers Krossguard not working after reflashing with own config

Sup,

So I got my Krossguard with a Proffie v3.9 yesterday. I received the original config and went from there as usual (this is not my first Proffie config I wrote multiple) and modified it with the Blade Styles and respective #defines I wanted on the saber.
Before I flashed the board, it was in perfect working condition, it lit up, sound was there and the crystal chamber lit up as well.

After flashing the SD Card, then flashing the proffieboard the saber has no sound and no light anynmore. The LED on the board itself is lighting up green and when I turn off the killswitch the 2 Buttons (Pwr & Aux) on the Saber itself are lit up for like a second and after that there is no more life signs from the Saber or the Board (apart from the green LED on the proffieboard being lit up).

I tried the following to remedy this issue:

  • reflashed the original config and SD Card configuratio
  • emptied out the config to one simple style and almost no defines, went from there and added more, but even with an “empty” config the saber would behave the same
  • I tried to use mutliple different proffieOS with no avail
  • I tried a different battery in the saber, no luck
  • I used the Blade Config part and created a new config on Fetts site, that didnt work as well.
  • I checked the solder joints and they looked fine.
  • I tried a different SD Card and no difference.
  • I tried all the above on another PC and same result.
  • I downloaded to config onto another proffie 3.9 Saber I have and it worked out there, so it cant be a config related thing I guess.

My thoughts: The upload to the Saber itself is kinda messy, It often gives out DFU device not found errors but then goes ahead to download the config onto the board.

When I look into the serial monitor, I get literally nothing.

I was hoping maybe some of you have an idea on what to do, Im outta ideas.

Im going to attach the config I am using.

Thanks in advance.

KGv3.h (75.6 KB)

Did that work?

In your config file, I see this:

 WS281XBladePtr<20, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin6> >(),
 WS281XBladePtr<20, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin6> >(),

This is neither valid nor necessary. I get that your krossguard has two quillions, but if they are wired in parallel, then you only need one “blade” to drive both of them. (Same as the two strips in your main blade.)

Having two identical blade definitions is going to become the same blade definition, and that blade is going to get activated twice, which could be why everything freezes up.

Hi there Prof,

thanks for your reply! No reflashing didnt work.
The Blade Config section was left as is from what I took out of the config provided by my seller.
Ill try to remove one line and reflash the config onto the saber. Ill give an update wether it works :slight_smile:

Apart from removing one of those two lines, you’ll also need to set NUM_BLADES to 2 and remove one style from each preset.

Yes, I did that, Ill compile now.
I sadly dont have a wiring diagram for this saber so I cant really tell how the quillions are wired up. Logic suggests they are wired in parallel as you said, but I cant be sure.

alright so, im very greatful for your help.
The Saber works again, although only one sideblade turns on the right one to be exact. I suppose they are seperatly wired then. I guess Ill have to add the other line again but define a different bladepin? What would be your advice here? Secondly the saber goes into sleep mode after like 10 seconds when the blades are off, maybe I got a hicup in the defines section?

Most likely it’s a different blade pin AND a different power pin as well.
Check the soldering to see which pads are actually in use.

When you say “sleep mode”, I assume you mean the fett263 gesture sleep?

here is a picture of the Proffieboard.

Not quite, its going into a sort of deep sleep, I need to press the power button to wake it up but then it also plays the boot sound every time. Which is kind of bugging me a lot. I dont want to hear the boot sound every time I turn the saber on XD

Does the serial monitor say anything when it goes to sleep and/or wakes up?

So, this board has LED4 and LED5 connected to something, but not LED6, as indicated in your configuration file.

Data2 and Data3 are both used. Only thing left to do is to see if it’s Data2+LED4 and Data3+LED5, or Data2+LED5 and Data3+LED4.

1 Like

The Serial Monitor Output is:

Activating SmoothSwing V2
Accent Swings Enabled.
Polyphonic swings: 16
Monophonic swings: 0
Accent Slashes NOT Detected: 
unit = 0 vol = 0.50, Playing KyloRen/boot/boot4.wav
channels: 1 rate: 44100 bits: 16
I2C init..
Motion chip ... 105 found.
EVWelcome to ProffieOS v7.14
For available serial commands, see:
https://pod.hubbe.net/tools/serial-monitor-commands.html
Unmounting SD Card.
Amplifier off.
Booster off.
EVENT: ?47 millis=19554
EVENT MENU TURN RIGHT
Battery voltage: 4.06
EVENT: ?48 millis=20613
EVENT MENU TURN LEFT

Im currently trying different combinations for the side blades, sometimes one is active sometimes only the main blade but never the left blade.
Do you have an Idea which combination of this I could try?

{ 0, WS281XBladePtr<133, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(),
    WS281XBladePtr<20, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin6> >(),
    WS281XBladePtr<20, blade4Pin, Color8::GRB, PowerPINS<bladePowerPin1> >(),
	CONFIGARRAY(presets) },

this for example only turns on the main blade.

Try:

WS281XBladePtr<20, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin1> >(),
WS281XBladePtr<20, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin4> >(),

If not that try:

WS281XBladePtr<20, blade2Pin, Color8::GRB, PowerPINS<bladePowerPin4> >(),
WS281XBladePtr<20, blade3Pin, Color8::GRB, PowerPINS<bladePowerPin1> >(),

thanks, Ill try that.
Although the Original lineout used powerpin6. Ill try anyways.

That is confusing. I’m just going by what I see in the picture.

Oh wow, that is cool, it instantly worked!
Thanks so much, Ill have to dig into the Hardware side of configs to get a better understanding.
Im installing my first saber tomorrow! That is going to be an interesting journey.

Now, only thing to get sorted is how to get the Saber to stay “ON” longer then 10 seconds after the blades are off and how to get the blades back to how it was when I received the saber, that the quillions have a delayed activation.

Thank you so much for all of your help, i really appreciate it guys.

1 Like

The delayed ignition will be controlled by the individual styles. You can make new styles and set delays for them with Fett’s library. It’s pretty easy to do.

Did you by chance change the motion timeout define at all?

I see your board has solder on the 5V pin… I’m still waiting for them to explain to me what they are using it for… I did get confirmation that ALL of their current V3.9 inventory are soldered that way.

Aaah ok good to know. Ill look at it tomorrow.

No i havent changed anything in regards to timeouts.

Hmm interesting.

Also, unless your crystal chamber has 20 pixels, you may want to change the number of pixels in the blade config to match.