Missing Lockup End effect Layer on 6.x . works 5.9

I can’t figure out why this layer is not showing. Works on 5.9.
Using stock saber.h prop. This is the Lockup:

TransitionEffectL<TrConcat<TrInstant,Strobe<GreenYellow,Black,20,30>,TrFade<200>,BrownNoiseFlickerL<AlphaL<White,Int<16000>>,Int<5000>>,TrJoinR<TrWipe<200>,TrWipeIn<200>,TrFade<300>>>,EFFECT_LOCKUP_END>,
    LockupTrL<Layers<
      // Bottom Layer Bump - random width
      AlphaL<Blinking<Tomato,Strobe<Yellow,Black,15,30>,60,500>,                                                          Bump<Scale<BladeAngle<5000,28000>,Scale<BladeAngle<8000,16000>,Int<3000>,Int<44000>>,Int<3000>>,Scale<SlowNoise<Int<3000>>,Int<8000>,Int<18000>>>>,
      // Top Layer bump - fixed width
      AlphaL<Blinking<BrownNoiseFlicker<White,Black,50>,BrownNoiseFlicker<Yellow,Tomato,50>,100,500>,          Bump<Scale<BladeAngle<5000,28000>,Scale<BladeAngle<8000,16000>,Int<3000>,Int<44000>>,Int<3000>>,Int<9000>>>>,
      // Begin Lockup Transition
      TrConcat<TrInstant,AlphaL<Blinking<White,Strobe<BrownNoiseFlicker<Yellow,Black,500>,Black,15,30>,60,500>,Bump<Scale<BladeAngle<5000,28000>,Scale<BladeAngle<8000,16000>,Int<3000>,Int<44000>>,Int<3000>>,Scale<SlowNoise<Int<3000>>,Int<25000>,Int<32000>>>>,TrFade<500>>,
      // End Lockup Transition
      TrSmoothFade<900>,SaberBase::LOCKUP_NORMAL>,
    TransitionEffectL<TrConcat<TrInstant,AlphaL<Strobe<GreenYellow,Black,20,30>,                                          Bump<Scale<BladeAngle<5000,28000>,Scale<BladeAngle<8000,16000>,Int<3000>,Int<44000>>,Int<3000>>,Int<15000>>>,TrFade<600>>,EFFECT_LOCKUP_BEGIN>,
    TransitionEffectL<TrConcat<TrInstant,HumpFlickerL<Strobe<AlphaL<White,Int<20000>>,Black,20,30>,30>,TrSmoothFade<250>>,EFFECT_LOCKUP_BEGIN>,
    TransitionEffectL<TrConcat<TrInstant,GreenYellow,TrDelay<25>>,EFFECT_LOCKUP_BEGIN>

Serial monitor is no help here. Any idea what to look for? Could someone test it?
The first line, the EFFECT_LOCKUP_END should show a flash of GreenYellow with a BrownNoiseFlicker being Wiped from center.
All I’m getting is the TrSmoothfade<900> of the impact location bump.
EFFECT_LOCKUP_BEGINs all showing fine.
Thanks.
-Stumped

Does it matter what prop you use?

It does not.

So is the problem that EFFECT_LOCKUP_END just doesn’t work, or is it something more complicated than that?

EFFECT_LOCKUP_END works for other styles with different Lockups. Something about this one is not showing it (as a separate TransitionEffectL). The LockupL template’s end transition is showing ok. I’m going to start slimming it down and testing eash phase to see what change makes it work (if it does at all, which it totally should at some point)

No slimming has helped. This simple test style works fine on 5.9, but does not show the end lockup layer in 6.x.

StylePtr<Layers<
  Black,
  AlphaL<Red,Bump<Int<0>,Int<6000>>>,
  TransitionEffectL<TrConcat<TrInstant,Rgb<0,0,150>,TrDelay<1000>>,EFFECT_LOCKUP_END>,
  LockupTrL<AlphaL<White,Bump<Int<16384>>>,TrInstant,TrSmoothFade<900>,SaberBase::LOCKUP_NORMAL>,
  InOutTrL<TrWipeSparkTip<White,300>,TrWipeInSparkTip<White,300>>>>()

Try moving the END layer after the lockup, you may be masking it.

Hopfully I have time to try this tonight.

1 Like

Yeah, thanks. That’s where it was in the first place and that worked fine on 5.9. Then when updating a saber from 5.9 to the latest I noticed the missing effect when testing. I moved the layer to the bottom to test and actually like the blend it makes when there better. Still, no go on 6.x. Odd.
I also tried to just put all of the begin/end effects back into the LockupL using TransitionEffects and internal layers etc… , but the resulting effect is just not the same when they all are ruled by the same fade transition time. Hence why I had them broken out to their own simultaneous layers in the first place.

Might be EFFECT_LOCKUP_END in general.
I just grabbed the Examples Layer style from the Style editor and added this Layer on top of everything but InOut and it does not show.

StylePtr<Layers<
  Red,
  ResponsiveLockupL<White,TrInstant,TrInstant,Int<26000>>,
TransitionEffectL<TrConcat<TrInstant,Green,TrDelay<1000>>,EFFECT_LOCKUP_END>,
  InOutTrL<TrWipe<300>,TrWipeIn<500>>>>()

I think this should be fixed on github now.

Confirmed. Thanks.