LEDs not working

Pretty new to Proffieboards. Got my first one from VireSabers and installed it. All was good but now all of the sudden my blade doesn’t light up when it comes in contact with the LEDs. The LEDs go static when my blade is contacting the pins, and will only work right when the blade isn’t touching them.

Sounds like a power problem.
What battery brand/model do you have?

Uploading: image.jpg…
This is what I have.

I don’t know if the image is going to upload, but it says CustomSaber and is 3600MAH 10A

I prefer text over images for simple information like that anyways.

A 10A battery should be good enough, unless it’s gone bad in some way.
Have you tried charging it?

I can leave the saber charging while I’m at work. but that’s over 7 hours of charge.

The charger should stop once the battery is full.
(If your charger doesn’t do that, get a new charger.)

I figured, but just wanted to be sure. I’ll update you in around 8 or so hours about if charging it fixes my issue.

Still doesn’t work. I may need to replace all the files on my sd card but i lost my backup, so unless somewhere here has the files that go into the viresabers proffie core sd card then I gotta wait for them to give me the files.

Even with the right files, I’m still having the issue.

Maybe take a video of the issue so we can understand what is happening better?
(Post it on YT or google photos, then link here.)

I think I may have figured out what happened. tested the blade outside of the hilt. shorted the plug and blade. already ordered new ones. I got a cracked blade that came in today so once I get home I’m gonna test it out