Having trouble adding blade styles to my proffieboard

So I’m having some trouble adding blade styles to my proffieboard. So far there are two main issues. The first one is that half of the time when I turn the blade on it either has glitched lighting or it just doesn’t light up at all but I still have sound when I swing it around.

The second issue is that when I flash my board the illuminated power button doesn’t light up anymore. I have tried to upload the original files from Sabertrio and then everything works perfectly. Does anyone have any idea what might cause these issues?

I have a proffieboard V2.2 and using Arduino 1.8.19

Down under is the newest config i tried, I have had the same issue with multiple configs.
Fett263config.h (8 KB)

You have 2 blades set up so you need 2 styles per preset but only have 1.

I suggest trying this tool, it will help with syntax and set up. Just watch video and read through everything.

Make sure your blade is fully seated and secured, it sounds like your blade is losing connection.

Thank you, I will try this and see if I can figure it out.

So I tried using the config helper and when I pasted in my original blade config from sabertrio it says that my blade config contains 0 blades in it, do you see something that sticks out?

This is my original blade config.

BladeConfig blades[] = {
{ 0, WS281XBladePtr<144, bladePin, Color8::GRB, PowerPINS<bladePowerPin2, bladePowerPin3> >(),
SimpleBladePtr<CreeXPE2WhiteTemplate<550>, NoLED, NoLED, NoLED, bladePowerPin1, -1, -1, -1>()
, CONFIGARRAY(blade) },

That’s an incomplete BladeConfig see example below the input field