Fonts and Styles Not Appearing, Edit Mode Not Starting

Hi all, thanks in advance for any advice. I have no idea what’s going wrong, and I wanted to hold off on posting an open-ended issue here, but I’ve been working at this almost non-stop for three days and I feel like I must be missing something extremely obvious.

I’m completely new to this, so please let me know if you need any additional info.

I’ve got a Proffie 3.9 installed by TCSS, I received it a week or two ago and I am pretty sure it’s running OS7.9, as that’s the only OS I’ve downloaded and installed for the setup process. It’s a two-button, single blade saber with a KR blade, no crystal chamber, quillions, or accent LEDs. Here is the config it shipped with from TCSS:

I don’t know why it’s set up with 5 blades in the blade config, but I read that I shouldn’t edit that so I’ve left it as-is in all configs since.

Specifically, I am trying to install two sound fonts and three blade styles and get into Edit Mode to use them. The fonts came from Saberfont and the blade styles came from Fett263’s style generator (enormous props to Fett263, the amount of work you’ve done for this community is astounding and I’ve almost exclusively relied on your resources to get my bearings the last couple of days). Here is the config I generated using his config optimizer tool and edited to have the same number of presets present in my original .ini:

This config compiles and uploads without any issues, and I’ve followed Fett263’s SD formatting guide for my SD directory, so I’ve got a common folder with the edit mode menu sound prompts and a shared tracks folder. The only font I have so far with its own dedicated track has a track folder of its own. I did play around with editing the .ini by hand, but I was a little confused by the preset designations and thought it might be safer to learn edit mode. As of right now, it’s starting up as if I hadn’t uploaded a new config at all and running the default 6 fonts it shipped with.

I wanted to get to a place where I could identify whatever issue I’m having before posting here, but I’m not getting any error messages anywhere, and while I’ve successfully been able to add one font and blade style with ProffieOS workbench, I’m not really happy with how that process worked for a couple of reasons and I’d rather just learn how to use edit mode. I’ve watched a couple hours of Fett263’s videos on the subject, and I’m just not sure where to go next, so rather than keep spinning I figured I’d post here.

Any help is greatly appreciated!

You need Editable Styles, you’re using a very old style and syntax. Use the OS7 style library to generate Editable Styles.

That’s strange, I’ve generated all of this from the 7.12+ tools, so I’m not sure how I got the old syntax. Is it just the style code syntax that’s off, or is it a larger issue with the config or the Using Function? I tried generating new style codes from that link for a fresh config and it looks the same to me.
The main issue that I’ve noticed is that edit mode won’t open at all; when I hold AUX and PWR nothing happens.

These styles in the config you posted were not generated from any current library.

Anything that starts like this is very old.


Edit Mode enabled styles will begin with a copyright and comment section with all of the selections listed and contain editable arguments like BASE_COLOR_ARG, etc.

Are you sure you’re actually uploading the config you think you are?

I would get editable styles first, then make sure you’re actually uploading the right config successfully.

Also DO NOT USE this define unless you fully understand what it means. If you’re just starting out do not use this until you understand how everything works or you’ll be banging your head against the desk trying to fix things.


Oh, I see, my bad: the StylePtr<InOutHelper< blade styles are what came from the original TCSS config, I thought I needed to keep those in the config for the presets to work. Does this look more correct? I did not add the KEEP_SAVEFILES_WHEN_PROGRAMMING define to this one.

That’s a new config with only blade styles generated with the OS7 library.
And you were right, I was uploading wrong. I went through and attempted to upload correctly, which got me a DFU error. I tried running proffie-dfu-setup again and got the same error, so I went through and did the Zadig process instead, and I still get the following error on my upload attempts:

I have two serial ports showing up now (COM1 and COM3 USB), and I’m getting errors attempting to upload to either of them, even when the board shows up correctly in devices as Proffie or STM32 BOOTLOADER. I’m not sure what to do about that other than restart and retry the driver solutions again.
On the plus side, when I hold down AUX and PWR it says “SAVE” now lol

Hey How are you doing,

everything I said was WRONG. don’t mind me. looks like you added all the style codes for each blade and I did not read the rest of the config. OOPS. I did however do a search and found this forum post

it outlines a dfu program you can run and how to rerun the zadig driver. I’m assuming you’re on a windows pc?

1 Like

Oh yep, that’s absolutely what it was. The driver for my HOTAS is the same guillemont driver. That’s unfortunate, but those are fairly easy to reinstall if I want to in the future.
I ran proffie-dfu-setup again and it’s working now! Blade styles, fonts, and edit mode all seem to be good to go.

1 Like

yeah, glad to have helped. there’s always a good chance that any errors will be here so it’s always good to do a search first and then go from there.

1 Like