Font Directory Not Found and Board not Updated

Hello, I have a ProffieV2 board wired to a tri-cree led saber and I am trying to reprogram it to OS6.9 from its base state. I went through many different steps, added the common and moved tracks there, used the Config helper and wrote up an OS6 compliant config file with correct stats and compliancy for the tri-cree led (which works and is recognized in arduino) and when I try to upload it through arduino it says that it uploads completely, the saber disconnects from the computer and makes a confirmation sound. However when I try to turn on the saber it says “Font Directory Not Found” and only activates the tri-cree led in my saber. It also seems as if it didn’t actually update the OS as it doesn’t feature the gesture controls I put into the config. What can I do to update my board, and what am I doing wrong, or not doing right?

Step #1, read this: ProffieOS Documentation: Is it uploading?
Step #2, post your config file.

Additional questions:

  1. Are you using the Fett263 prop?
  2. Do you have a voice pack in the common folder on your sd card?

Thank you for the quick response and the help is very much appreciated, I read the documentation and I will try that now, I am in fact using the Fett263 Prop and there are indeed voice files in my common folder in the sd card. For now here is a link to my config file:
roninOS6_config.h (3.1 KB)

The screenshots you posted were not helpful and just take up space on my server, so I deleted them. (Also, please take a moment to review the rules about screenshots on this forum. Your screenshots did not really break these rules, I just want you to be aware.)

Please let me know how the upload goes.
Next step will be to check the serial monitor.

My apologies, and thank you I am aware of the rules. I installed the driver and the update worked perfectly, however now my tri-cree led will not light at all. I will take it into my shop today and figure out if it is a lighting issue. Thank you for your help. Do you have any tips for me on the led portion if it isn’t a wiring problem?

All of your presets are set to:


This means they LED will always be Off. Add a Style to each preset that actually lights up the blade and it should work :wink:

I tried plugging it into my computer to edit the config with bladestyles using the same micro-usb I used to update the os and now my computer wont open the sd-card like it used to. It recognizes the board but it seemingly cannot find or will not open the sd while its plugged into the board’s micro-usb port and it was working before the update.

Never mind on the sd-card issue. I had flashed a new config enabling the serial port and its working perfectly, and I flashed the new bladestyles along with it! Thank you so much for all of your great and quick help guys!

Select “serial + webusb + mass storage” from Arduino → Tools → USB Type and re-upload.

Thank you so much! Works beautifully!