Does which LED1,2,3,4,5 Matter for Blade GND?

I had to unsolder my blade connector to fix a switch that was loosening up and making my chassis loose, but even with a solder suck or wick I can’t get the board holes clear again and I’m worried I’m going to overheat the board and mess things up.

According to the Proffie PDF, I wired my Neopixel blade plug GND to LED2,3. Can I re-wire to the never-used and clean LED4,5?

Absolutely, you just have to change your config to operate those pads instead of LED1/2 and everything should work fine.


Well, I did manage to get the solder sucked out of the through holes and get it wired back up. Sadly, I think I managed to cook my board. Powered it on, and the sound is intermittent and crackly, and distorted.

Enjoy my out of practice bad soldering, and a crispy looking board.

Crackly sound often means a bad 5v supply. (Or, possibly that you have magnetic stuff stuck to the speaker.) Have you tried measuring the voltage between gnd and 5v?

Nothing stuck to the speaker, but I will check the voltage.

I also noticed this wayward blob of solder:

Looks like that solder blob is touching C61. C61 is needed to have a stable 3.3v rail. An unstable 3.3v could potentially cause audio issues (and lots of other problems as well). Maybe try to fix that solder blob and see if the board works better…

Cleaned the solder off of C61. Left the board floating (not seated down in the chassis) and popped the battery in. Got clean audio and it was working find. Pushed the board down into the chassis and taped it down with kapton tape, re-inserted the battery…back to messed up sound. Took off the tape, pulled the board up a bit, turned back on and the sound is back to messed up.

Also, now that it’s back to messed up, if I move the hilt around, it makes a blade clash noise and/or set of tones (like 6-7 tones in a row, like old school rotary dial noise), even though no soundfont is active, it’s just on.

Lastly, with sound playing, I was only getting 0.2(and some change) volts when measuring between GND and +5V Out (using a good Klein auto-range meter).

Looking a little better:

Beep noises are normal, check the serial monitor to see what it’s trying to do or complaining about.
0.2V between GND and 5v pad may also be normal, since it’s only powering that pad when sound are being played, or when blades are on. When neither of those are true, the 5v pad will have little or no voltage.

The fact that it got messed up when you pushed it down makes me think that some of the wires were touching the board or each other under the board.
Also, the sound and 5v parts are all on the bottom, so if there is a problem with the sound, it’s most likely on the other side.

Oh, and check that your battery is charged!

Serial monitor?

The 0.2V was with a soundfont active (no blade in) and audio playing.

I’m not seeing anything touching, although that was my first thought too. Weird that it worked just fine and is now back to being ‘broken’.

Battery is 99% charged. Also, I just realized looking at the bottom of the board, this is your board, you designed the Proffie?! Well shit, no wonder you are so knowledgeable!

Not sure if it helps to see the underside of the board, but here it is. Looks ok to me?

Yeah, that’s not good.

You learn something new every day! :slight_smile:

The only thing in the image that looks potentially concerning is the red BATT+ wire which could maybe touch the capacitor next to it when bent?

Here’s the Serial Monitor output:

EVENT: Aux-Shortclick ON millis=188563
unit = 1 vol = 0.50, Playing Rotoscope/blst/blst4.wav
channels: 1 rate: 44100 bits: 16
Playing Rotoscope/hum.wav
channels: 1 rate: 44100 bits: 16
Playing Rotoscope/swingl/swingl1.wav
channels: 1 rate: 44100 bits: 16
Playing Rotoscope/swingh/swingh1.wav
channels: 1 rate: 44100 bits: 16
EVENT: Power-Pressed#1 ON millis=190523
EVENT: Power-Pressed ON millis=190523
EVENT: Power-Released#1 ON millis=190829
EVENT: Power-Released ON millis=190829
EVENT: Power-Shortclick#1 ON millis=190829
unit = 1 vol = 0.50, Playing Rotoscope/in/in1.wav
channels: 1 rate: 44100 bits: 16
No sounds found: pstoff
Amplifier off.
Unmounting SD Card.
Booster off.
Battery voltage: 1.65

The only thing in the image that looks potentially concerning is the red BATT+ wire which could maybe touch the capacitor next to it when bent?

I will double check that, but it shouldn’t be touching.

Is that when it’s beeping?
I don’t see anything wrong with it.

It wasn’t making any beeping. That’s running off of the USB power, no battery in the chassis, hitting the ignition button and letting it run for a bit.

I’m assuming I would need to upload a video to youtube and link to show what’s it’s doing with sound? Also, thanks for taking the time to help with this.

Yes, a youtube video might be helpful in showing what’s going on.

Here’s the video, hopefully this is enough to hear how distorted the audio is:

Sound Issues

Check this out, it starts this audio sounding fine and then slowly goes to shit?

Also, I do have a resistor on the +3.3V Out (ignition button has an LED). Not sure if that matters, but just figured I would mention it.

I’m wondering if the second video is because the volume of the sound goes up.
In general, when the 5v supply is bad, you usually have better sound at low volumes than high.

At this point, If you have warranty on the board, you might want to try to get a new one. If not, you might want to try briding batt+ and 5v and see if it works better.

1 Like

No warranty that I know of, bought it with my Saber kit from Saber Armory.

Also yes, if I set the volume to the lowest level, it sounds ok-ish, but still crackles on the highs when swinging around.

Bridging the Batt+ and 5V is safe to do? If it works fine then, still suggest replacing the board?

One more interesting thing I just noticed, if I use the 2 button command for the audible battery level, even though it’s at 95% charged, it says “Battery 0%”.

Bridging BATT+ with 5v is relatively safe. The result is lower volume, but good sound, assuming that the problem is with the 5v supply and nothing else. It’s up to you if you want to replace the board after that.

How do you know the battery is 95% charged?

Also, have you tried measuring the voltage between BATT+ and GND?

So, I bridged BATT+ and 5V and it sounded perfect, functioned perfect, although the main chip (STM32L) felt pretty toasty (but not so hot that I couldn’t keep my finger on it). So, I un-bridged that connection…and it’s magically working fine now? Ran it for about 15 minutes, cycled through all the sound fonts, and it sound perfect, even with volume at max. It was also reporting the battery charge, using the audible menu, accurately again. So…strange?

I did notice one or two times where it ignited a font without any audio, and some times the main switch seemed unresponsive(?). But otherwise it seems to be back to normal. Main chip felt warm, but not hot, which I assume is normal. I might still order a replacement board just in case.

I have an intelligent charger (Golisi S2) and that is where I got the battery percentage from. I did not re-measure the BATT+ to GND.