Cannot open DFU device error

I know that there are multiple different posts on this error, but I think I’m having a completely different issue, whenever I try to flash my board I get this error 10 times:

Cannot open DFU device 0483:df11

My arduino was working perfectly fine last time I tried it but now it keeps popping up this error, I don’t know what to do, my saber works perfectly fine and I’ve tried 3 different config files and it still wouldn’t work.

You need to run proffie-dfu-setup.exe, see “OS specific setup” here:

Alright I’ll see if that works.

I’m probably being an idiot right now but do I have to restart my computer or do anything else with arduino to get it to work?

No, it should just work.

Oh, thats not good, it still isn’t working

Do you have any other ideas on what I can try?

So you could try following the Zadig instructions:

Zadig and proffie-dfu-setup.exe do exactly the same thing, but zadig has UI and may give you a clue as to why it’s not working.

My guess is that you have some other driver installed that is interfering with the Proffie DFU driver.

Is there anything else I can try before I have to try zadig? I know this sounds stupid but I’m kind of worried that pressing the reset and boot buttons down will mess something up.

Also this is the full error message

c:/users/david/appdata/local/arduino15/packages/proffieboard/tools/arm-none-eabi-gcc/9-2020-q2-update/bin/…/lib/gcc/arm-none-eabi/9.3.1/…/…/…/…/arm-none-eabi/bin/ld.exe:C:\Users\David\AppData\Local\Arduino15\packages\proffieboard\hardware\stm32l4\3.6\variants\STM32L433CC-ProffieboardV2/linker_scripts/STM32L433CC_FLASH.ld:224: warning: memory region `SRAM2’ not declared
Sketch uses 212928 bytes (81%) of program storage space. Maximum is 262144 bytes.
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11
Cannot open DFU device 0483:df11

You can check what driver is actually in use.

To do that you would:

  1. connect the board to the computer
  2. (eject safely if needed)
  3. hit upload, wait for it to fail
  4. find the device in “devices and printers” or the device manager. (It will be called “STM32 BOOTLOADER”)
  5. right-click and select properties, then “drivers”
  6. The driver should be WinUSB if I remember correctly. If it is something else, then that something else is probably what is interfering.

I am having some trouble finding the proffieboard in the device manager but Zadig said that the installed drivers were GuiSTDFUDev (v6.8.3.0) and I’m 100 percent sure these are the wrong drivers.

So to correct the drivers I would have to press the reset and boot buttons and use Zadig to install the WinUSB drivers right?

This is a guillemont joystick or racing wheel firmware update driver.
It’s likely that something will re-instate this driver immediately if you try to use Zadig or proffie-dfu-setup.exe to make it use WinUSB instead. If at all possible, I would recommend uninstalling the guillemont driver.

Well I uninstalled the drivers and then arduino immediately started working again. Thanks for the help.

It might take over again.
If you don’t need them, you can delete these folders:

C:\Program Files\Guillemot
C:\Program Files(x86)\Guillemot

1 Like