Board not recognized

I can’t get my board to get detected, whenever i plug it in i get the usb device not recognized, and i can’t use zadig to reinstall the driver. hitting the buttons to reset the board also does nothing.

Try a different cable.
9 times out of 10, it’s the cable.

Even with a new cable I’m getting the same error

Is it a data cable?
Does the board work, or is the board dead?

it is a data cable, and i’m not sure if the board died. i was mid flashing a config on it and moved it slightly and the cable disconnected slightly and now it won’t connect to my computer.

the chip on the board is incredibly warm though

That’s not good, that might mean that the board is actually fried.

I should add that disconnecting the board in the middle of programming should not cause any permanent damage, it should just be a bad programming, which you could then recover from with the instructions above.

However, it may be that something worse happened, I’m just not sure what.

ill keep trying to press the buttons. it is difficult given the fact they are so worn down.

Try a 2x8 flat lego piece.

still not getting anything, and the chip isn’t cooling down one bit.

got the audio queue from windows that i pressed the buttons, but then it immediately said usb device not recognized.

and plugging in my saber to charge the leds in the neopixel connector turn red… something’s definetely wrong. will contact my vendor.

Usually this just means that windows has detected that something is drawing power from the USB port.

now plugging it in will cause it to make a continuous beeping…

Not sure you’re doing the buttons right.
Try instead to just hold BOOT (make sure you feel it click) then plug the USB into the computer, then release BOOT.
Then hit upload in Arduino, regardless of it not showing up in Tools>Port.

It’s hard to hit the buttons, I don’t really feel a click from them anymore, but regardless it still does not work.

and the chip still gets incredibly hot.

Which is an indication that something is wrong.
The chip is not supposed to get hot.
Sometimes it works anyways, but it’s definitely not a good thing.