At a loss on first build

This is my first saber build but I like to think I’m good figuring stuff out but I’m at a loss.

K4V2 build with thin neck wiring and Proffieboard 2.2 with 6.7 OS.

One moment the saber turns on fine (using the kill switch) and everything works perfect. Main blade, CC, bubble strip, 3 NPXL accent lights, and the Oled screen. Sounds good and looks good. I shut off the kill switch and go back later and it’s literally 50/50 if it turns on at all. Nothing… no sound, no Oled, no lights - just nothing.

I know the board is getting power- I have tested the board’s batt+, 5volt, and 3.3 volt and they all look spot on (even when the saber won’t turn on) - so I know the board has power.

I have all the lights’ positive lines going up to the Shtok connecter in the chassis. For a moment I thought maybe a bad joint there but wouldn’t I still get sound and Oled (which are all wired directly to the board?)

I do have a bt630 (from the Saber Armory) installed but not fully defined in the config, could this be part of the issue? I currently have the following in the config but I haven’t added the Bluetooth to the blade count nor have I added a Bluetooth blade style.

#define ENABLE_SERIAL
// Max 20 characters
#define BLE_PASSWORD “your password”
// Max 32 characters.
#define BLE_NAME “Your Saber Name”
// Max 9 characters
#define BLE_SHORTNAME “Saber”

Any thoughts would be much appreciated. Thank you!

Do you have an extra capacitor between 3.3v and GND? The bt630 module can mess with the 3.3v power supply, making that required. Although, if the bt630 module is hooked up to a LED pad, and there is no style driving that pad, then the bt630 module shouldn’t have an impact.

Unfortunately, it’s difficult to know what’s happening here, so it’s probably time to start experimenting. It could be a bad SD card, it could be a poor battery, it could be a bad solder somewhere, it could be a bad board, it could be something in your config file…

First thing I would do would be to pair the config file down to it’s simplest form, no OLED, no accent lights and no complicated blade styles. Then try it a few times and see if that helps. If so, we have a clue and we can fix it.

You might also want to try ProffieOS 7.x alpha to see if that makes things work better because it interacts with the SD card differently.

Next, try a different SD card and see if that helps.

Then a different battery.

Then it’s time to start de-soldering stuff. Does it work without the oled? without the bluetooth module? without blades?

If you reach this point, then everthing external has been de-soldered and the software has been ruled out, then it’s time to start blaming the board itself…

Awesome, thanks for pointing me in the right direction with things to test.

Yes, I do have the correct capacitor between the 3.3 and ground pins for the BT.

Batteries… I will say I started with a cheap generic battery because I already had it. I then bought two 15amp batteries from the Saber Armory. The saber hardly ever turned on with the cheap battery but, with the new batteries, the saber turns on much more frequently, but still intermittently…

I will go through your list and hopefully it’s something simple🤪

Thanks again!

Oh, by the way, the BT is connected to LED 6…

Maybe also post your config file and describe exactly how everything is wired.
If there is a problem there, maybe someone (like me) will spot it.

If changing battery helps, then it’s likely that the problem is power related.
Maybe also make sure that your solder joints are good? (measure resistance through them to make sure it’s low)