Are there issues with Proffie OS6 connecting to Win 10 PC?

I originally posted about 3 months ago, after purchasing an LGT saber with OS 6.5 installed. I own 3 other LGT sabers, all with 5.9. When I connected the 6.5 saber to my computer, it chimed and a message came up, but it did not connect. After reading several posts on multiple sites, I found that there was apparently an issue with a U40 chip on a batch of LGT Proffie cores. Long story short, the seller sent me 2 replacement cores, and both did the same. I later read that because of LGT programming, it may actually be an issue with the Web USB or STM32 Bootloader. I tried reflashing the newest core - chimed, but didn’t work. In Arduino, did not show the STM32 Bootloader, even after reflashing. I also tried reloading the config file through Arduino, and followed a step-by-step process from Absolute Sabers site, but when I got to the part where you click to compile sketch (and verify the config is correct), got error message back, which I shouldn’t have since I made no changes to the config. Sent all of the cores back to the seller, who said that they all worked for him so must be a problem with my computer/USB ports, even though there are no issues with my 3 other sabers and I tried multiple ports. He refuses to contact LGT or re-program on his system and we have agreed to return and refund. Here is my question (finally!) I want to order from a different vendor. I’m concerned that maybe this is an issue with OS 6.* and Win10…the vendor was using a Mac. Why would 3 different cores with OS 6.5 not work on my PC, but 3 with 5.9 will, unless it has something to do with 6.? And why would i be unable to re-load the config, unless it’s an issue with 6.? (I have uploaded configs on my 5.9 sabers with no problems). Have you heard of issues with OS 6.* not working with PC’s? I don’t want to order from a different vendor and have the same issues - just spent almost 4 months dealing with this one. Thank you for your thoughts and info with this!!

So, I don’t know what happened, and I don’t know why it wouldn’t work with your computer. I don’t know what error message you got, and I don’t know what you mean by “did not connect”.

I’m happy to help figure out and fix these problems, but since I don’t know what happened and you don’t have the boards anymore, I don’t see what I can do.

I’m not aware of any issues similar to what you are describing.

Thank you for your reply :slight_smile: Since I am returning the saber, I didn’t want to fill a long diatribe of info when I will not be trying to repair that one. To try and summarize, when I would connect all 3 of those new boards, they would chime, a quick message would pop up saying a new device was detected (or something similar - popped up and disappeared very quickly), but then it was not discoverable in File Explorer, and when I would try to disconnect it using the “Safely Remove Hardware and Media” icon in the lower right taskbar, none of them even showed as being present. To this day, when I plug in my other sabers (programmed with OS 5.9), they all show up on File Explorer and in the “Safely Remove Hardware and Media” icon, where they can then be ejected. There was a post on this site and on a popular YouTube site, as well as another authorized LGT vendor that I contacted, that all verified that there was an issue with a batch of Proffie boards that generated this issue. When I returned all of the cores to the vendor I bought the saber from, he responded and said that he was able to connect all to his computer and have them recognized in Arduino. He took one of the cores and added his own config to it and sent me a video showing that it was recognized by the “Safely Remove Hardware and Media” icon and said that the problem must be with my computer. He had no answer as to why I have no problems connecting my other 3 sabers with OS 5.9.

The guy from the YouTube site said that LGT sometimes has issues with programming the Web USB when they program these boards (forgive me if I’m not wording this correctly - I’m still pretty new at this) and recommended that I try re-loading the config. I downloaded the latest version of Arduino and Zadig and OS 6.7 (I couldn’t locate 6.5) and followed his online video step-by-step (which I previously used on 2 of my 5.9 sabers without any hitches), but when I got to the part where you compile the config and it checks to verify the config is correct, multiple error messages came up. Since the config was what was already on the board and what was stored on the SD card and I did not make any changes to it, I did not write down the error messages because the point was that it didn’t work, and I had no problems doing the same procedure on a 5.9 board.

I also read that re-flashing the board may work, and that one of the things to look for was the STM32 Bootloader showing in the Device Manager if done properly. I plugged one of the new cores in, checked Device Manager, and the Bootloader was not showing. I reflashed the board, and the screen on my PC refreshed, but the Bootloader still did not show. When i plugged one of my 5.9 cores in, the Bootloader showed in Device Manager.

The vendor also claimed that because he was able to get all 3 new cores to show in Arduino, that meant they were functioning properly. I too was able to get them to show in Arduino on my PC…I just couldn’t get them to show anywhere else, and I could not re-program them. I also tried connecting to the Easy Proffie OS site (where I have done much of my changes and additions on my 5.9 sabers), and the 6.5 cores were not recognized at the site, so I could not make any changes there, either.

So, that’s more of the backstory. For whatever reason, those 3 cores could not be “seen” on my Win 10 PC, and the vendor said he had no issues with them on his computer, and so they are being returned. I want to buy from a different vendor, but then the thought occurred to me…what if this is an issue between OS 6.* and Win 10, and not a hardware issue with the board? I don’t want to purchase from a different vendor, only to go through the same problem. Have you heard of any other conflicts like this that are NOT related to the recent defect coming out of LGT hardware? Have you also heard of the issue with LGT not programming some of their sabers properly, with regards to the Web USB issue? If these weren’t programmed properly in the first place, is this why I had an issue trying to reinstall the config? I would think not, but again, I’m rather new at this still. Finally, if there is an issue between Win 10 and OS 6.*, is it possible to reprogram back down to 5.9 to correct the issue, and if so, where do you locate older versions of Proffie OS?

Thank you again for any help you may offer!!

This just means the board was programmed without the “mass storage” option. It doesn’t mean anything is actually wrong. You can change this by re-programming the board.

That was a different issue, and the computer would not detect the board at all if that was the case.

None of the issues you’ve pointed out so far are related to WebUSB in any way though.

Zadig doesn’t operate on your sabers or proffieboards, it makes changes on your computer, and it should be enough to do it once per computer. (Although there are some people who need to do it once per board, but I don’t know why, Windows is mysterious sometimes.)

Compile errors have nothing to do with the board though. It just means that something on your computer (Arduino, ProffieOS, or something else) is not working properly.

I agree with the vendor here. The boards were working fine, they just were not programmed with the same options as your other boards.

The solution would have been to select an option that includes “mass storage” in Arduino → Tools → USB Type and then re-program the board. The errors you were getting programming the board were unrelated to any problems with the board, so you could have downloaded a fresh copy of ProffieOS and then it should have worked.

So you shouldn’t have to worry about hardware defects, because the problems you experienced were not hardware defects.

Thank you very much for your quick reply and trying to help me through with this. If I’m understanding this correctly, it sounds like I SHOULD be able to try re-loading the config, and just make sure that Mass Storage in Arduino indicates “Serial + Mass Storage + WebUSB” and this SHOULD correct the problem. Just a couple of concerns, though: 1) If that was the issue, why was the vendor able to get it to work on his computer, but it wouldn’t work on mine? Since I don’t have any issues when I connect other sabers with 5.9 on them, that would seem to eliminate my PC/Windows as the issue. But if the board was not programmed to accept Mass Storage, then shouldn’t the vendor also have the same problem as I did? 2) What exactly does “Mass Storage” do? It sounds like it prevents the PC from accessing it, if the correct setting is not made when programming it…is that correct? Is that why it can’t be “seen” under " Safely Remove Hardware and Media, File Explorer, and Easy Proffie OS site? If that’s the case, then how can I re-program the board if the PC/Windows can’t “see” it because of the original programming issue?

I’m sorry if I’m coming across as a noob (which I pretty much am)…based on what you’re saying, it sounds like I should give this vendor another chance, and try to re-program when he sends me the core back (for some reason, he will not just re-load the config himself, even though he sent me a video where he said specifically that he uploaded a “known good config.”

Thanks again for putting up with my noobness and trying to help me out!!! :slight_smile:

Answering these in reverse might be best.

First, you need to understand that programming the board has nothing to do with the SD card. The SD only stores the sound fonts (and a few system files).
Arduino doesn’t “see” the SD card at all. Only the PC “sees” the SD card if Mass Storage is uploaded as an option.
“Mass Storage” simply tells the board to use onboard SD card reader as an interface to the computer for the SD card to be read. This makes the board act just like a USB thumbdrive or any external USB drive you plug into the computer.
The only thing it provides is access to the file storage on the SD card via USB cable while the card is installed in the board. It is just as feasible to remove the SD card from the Proffieboard and to use a standalone USB/SD card reader. In fact, it’s much faster transfer speeds that way, plus you have less chance of corrupting the SD card because you forget to “Safely Eject” it before uploading for example.

Programming the board is completely separate from the SD card and is done via a direct serial connection to the board’s chip. No data is written/read from the SD card. It only holds sounds.
You can totally program a Proffieboard with no SD card installed at all.
Make more sense now?

Correct. More than likely, the vendor simply uploaded his “known good config” to the board with the “Mass Storage” option enabled, and verified it works as intended when that route is chosen.
But yes, AS-IS when you sent the board to him, it would not have mounted the SD to the PC.

Thank you for the explanation :slight_smile: Yes, I was aware that the SD card is just for holding the sound fonts, and is not involved with the on-board programming. I am, though, still a little confused…it sounds like the SD card is not being “seen” by my PC because of the Mass Storage issue, but what is stopping the PC from “seeing” the Proffie board? As I noted previously, when i plug my OS 5.9 sabers in, they all show in the “Safely Remove Hardware and Media” but none of the 3 new OS 6.5 boards showed. Also, the vendor of the new saber claims that his computer recognizes all 3 of the new cores, but he claims to have only installed a new config on one of them. This is what has me confused and wondering if I should accept his offer to get one of the cores back and try to re-load the config (still don’t know why he won’t do it - I am, after all, only the guy who paid $400 for the thing); should take the refund and purchase from a new vendor; or forget it because OS 6.* will not run on my Win 10 PC, for some reason (or can’t be corrected on my PC).

This is to “eject” the SD card. It doesn’t refer to the board itself which is a serial device.
If the SD is not mounted as a USB drive using “Mass Storage”, it wouldn’t be in that list.
When you have the board connected via USB, and the SD card is NOT mounted as a drive via “Mass Storage”, you just disconnect the board by unplugging. There’s no “ejecting” the board.

The Proffieboard will be seen by the PC in 2 ways when the drivers are correctly installed:

  1. as a Proffieboard composite serial device
  2. as STM32BOOTLOADER when it’s in bootloader mode.
    That’s it.

If you open Devices and Printers, you should see the Proffieboard as either one of these 2 devices.
When normally booted and running ProffieOS, the board is seen as “Proffieboard” and should show up in Arduino under Tools>Port
When booted in bootloader, it is seen as STM32BOOTLOADER, and is NOT seen in Arduino. This is how the board needs to be booted for installing the driver for STM32BOOTLOADER with Zadig. Once the driver is installed, the computer should know how to communicate with the board in either state.

Earlier in this thread, Proffezorn said that Zadig doesn’t operate on the saber or Proffie board, and should only be needed once on the computer. I have uploaded previous config files on other sabers and didn’t need to involve Zadig. My understanding is that I should not need to worry about Zadig any further at this point.

My 2 questions are: 1) when i try to upload a config to these boards that are currently not showing as STM32 Bootloader or on the “Safely Remove Hardware and Media,” what is the setting in Arduino that makes this happen/corrects this? From what I’m gathering, the Mass Storage issue addresses the SD card, and simply re-flashing the card didn’t correct this issue with the Bootloader, so what specifically needs to be done to ensure that the STM32 Bootloader correctly loads/operates and allows the Proffie Board to be “seen” by the computer? 2) I still don’t understand why the same core that cannot be “seen” on my computer can be “seen” on the vendors computer, especially when my PC has no problems with my other sabers?

I’m sorry if I’m not getting the obvious, but right now I’m still not sure that I should accept the core from the vendor and try to re-upload the config, because I’m still not sure what specifically needs to be done during this upload that will correct the current problem. So far, I know that Mass Storage + Web USB needs to be selected for the SD card, but what else during the install through Arduiino needs to be selected (and likely was not when LGT programmed this thing) to make sure I correct this other issue with the actual board itself?

Thank you again for dealing with this rookie

Don’t apologize. It can be confusing until you understand.
If the vendor says everything seems to be working I would take it back. It seems you just need to straighten yourself out on your end.
I’ll try to rephrase to make it understandable.
First of all, unless you are setting up your computer to talk to a Proffieboard for the very first time, you shouldn’t even need to use bootloader mode unless you had a failed upload.
When you hit the upload button in Arduino, it compiles your code. It looks on the COM port you selected for a “Proffieboard”… that is your board as normally booted and every day running ProfifieOS.
When it finds it because you have it set on Tools>Port, it then instructs the board to restart in bootloader mode so it can receive programming. The board restarts in bootloader mode (that’s when it’s STM32BOOTLOADER) and Arduino sends the programming. When programming is complete, the board restarts again in normal boot mode running your freshly programmed ProffieOS.

There’s nothing there you need to manually do or eject or anything. You literally just plug in the board, select it under Tools>Port, and hit upload.

  1. When you hit “upload” , Arduino sends magic control sequence to the port selected under Arduino → Tools → Port. This sequence tells the board to reboot into bootloader mode. After sending this sequence, arduino runs a script which waits for the bootloader to be detected by windows (1-10 countdown) and then does the upload to the board. After the upload, the board is rebooted again, but into ProffieOS, not bootloader mode.

  2. It seems that you’re still confusing “seen by the computer” and “the SD shows up as a drive”. The former is a prerequisite for the latter, but they are not the same thing.
    The correct way to find out if the board is “seen by the computer” is documented on this page: USB connection issues · profezzorn/ProffieOS Wiki · GitHub

Yeah. Mass Storage is not required at all. That’s just a convenience option so if you can’t get to the SD, or just don’t feel like removing the SD card from the Proffieboard. Like I said, you can upload programming to the board all day with no SD card inserted at all.

“Safely eject media” is the graceful action to take before removing an SD card when it’s mounted to the PC as a drive. Whether that’s mounted via the board using mass storage or using a standalone reader.
It has nothing to do with programming the board. It has nothing to do with Arduino seeing the board on a COM port.
Bootloader mode, when the board shows up to the PC as STM32BOOTLOADER only needs to manually be invoked when first installing drivers for it with Zadig, or if you need to force an upload because of an incomplete programming.

Thank you both for all your help with this!! After some additional discussions with the vendor, they are going to correct on their end, so looks like everything should be resolved. Thanks much for your patience and thorough explanations!!

1 Like