Apple Mac User Best Practices suggestions?

Edit: Anyone else having anything odd w the new M1 driven Macs?

I just traded in for a new MacBook Pro running the M1 chip and couldn’t get things running initially and ended up needing to download the newest ArduinoIDE. Got a field assist from @Lord-Anubis and just now finally got it working clean.

*Bonus was I got DarkMode!

I’m using 1.8.19 with no issues on a 14" 2021 MBP.

Yup, v1.8.19 w 3.6 is the ticket. Thanks

I just recently got an Apple M1 14" laptop. Dropped my older Arduino & ProffieOS configs onto it, which had Arduino 1.8.15. Arduino did not work. I upgraded it to 1.8.19 and it works fine now.
(My M1 is using OSX 12.5).

1 Like

@NitTheGrit Thanks, now I know it wasn’t just me and one other user.

Anyone else seeing that each time you have to select the board or the port? Like if you flash a single board back to back and it no longer recognizes it immediately?

Note: On the whole SD Ghost File Cleanup (SD_Purge), it appears with the new M1 and M2 chip variants once you’ve ran the initial cleanup on the files saved on the computer you may not need to re-run the cleanup. I’ve not seen ghost files with the new zsh change. On the stuff I’ve been doing the past few days I noticed that Terminal kicks back

Operation not permitted

and then

No such file or directory (your login/user name)@s -Mac(book) (Pro) PROFFIE %

@NitTheGrit and @Lord-Anubis can you also check and confirm or advise?

That’s a known big they’re addressing.

So it’s only a Mac thing? Good to know.


OS Ventura is showing issues with clearing out and reloading SD cards. It’s not a unique issue and relates to the drivers. Currently the workarounds only fix it so much unless you want to goto the trouble to revert to OS Monterey. You’re going to see slower file delete (Empty Trash) and upload times. Example, 33 fonts. Instead of the usual 2-3 minutes to clear the trash you’ll see 15 minutes plus with a need to click “Continue” a stupid amount of times in multiple order when it says it cannot complete a folder delete due to it being in use. Click continue each time and redo Empty Trash and click continue and repeat redoing trash until the trash clears. Then format the SD via SD Formatter. Note, SD Formatter is also producing an error due to the OS Ventura drivers where once it initializes and removes the SD card from the desktop you’ll get an error message. Just unplug the device (since the SD has already been disconnected) and plug it back in. When the SD icon reappears then start the SD Format and let it run through completion. Once that’s done load the fonts in. The usual 3-5 minute timeframe will now be at least 10-15 minutes.

Hopefully Apple pushes a bug update soon that addresses this. The times above are with the workarounds already done. If you’ve found a better solution by all means reply below as well as in the Apple Discussions topic. *Devices used were a 2018 MBP rebuilt to Monterey and a late-'22 MBP w factory Monterey, both pushed to Ventura in December.

What if you just hold Option when choosing “Empty Trash” from the Finder menu?

Solid idea but sadly the same result. A need to constantly click through “continue” and repeatedly re-empty the trash.

What files does it think are “in use”?
It’s probably being indexed by spotlight.

Add the SD card to list under the the privacy tab of spotlight in system preferences

The issue is anything starting from entire folder contents down through sub folders in the font folders themselves. Even common came up. *Note though, removing _extras in a bunch of two font maker’s products reduced it from happening so much, but it still happens. It’s easiest to show you this as it is going on, thus why I suggested a Zoom. Shoot me a reply via that DM and I’ll set time aside since I would like the community as a whole to have a better solution.

Ok but did you add the SD card to the Spotlight exclude list?

You can find what’s using the file in Terminal

sudo lsof | egrep 'Drag file here'

Yup, still did it. My personal opinion right now is DO NOT USE OS-Ventura until these bugs are worked out with an update or two. I reverted both our devices to OS-Monterey last night and things overall are working like they should. Even Arduino got faster.

1 Like

*I’ll clean up this reply in a week or so once everything shakes out. Possibly good news but I’m not calling this solved yet since I am still waiting for the official update release to see for sure. I still have common coming up in the Empty Trash progress box but it does it way faster now. 50 fonts upload in about 4 minutes and time involved to empty trash even with having to click through to get common to fully delete was a minute and a half.

I was asked to assist and try out Ventura (again) with some changes. Here’s the workarounds we used to get things to flow properly once you’ve gone to OS Ventura with the M1 chip. Note, while these are documented solutions in the past I assume no responsibility as the the usability on your specific device. It’s also suggesting doing both with OS Monterey as some users have found it applies there.

Install Rosetta. This relates to the bad cpu error due to how the new chips cannot read Intel-based software.

"... How to Install Rosetta 2 via Command Line on Apple Silicon Mac

Another way to install Rosetta 2 on the Mac is by using the familiar softwareupdate command line tool.

`softwareupdate --install-rosetta`

This will launch the rosetta installer and you’ll have to agree to a license agreement, which I’m sure you’ll read completely and thoroughly as we all do every time we install anything on every device.

You can also skip the license agreement by providing an additional flag:

`/usr/sbin/softwareupdate --install-rosetta --agree-to-license`

For some quick background, new Apple Silicon Macs run on different architecture, whereas Macs have been running Intel chips for quite some time. Rosetta 2 translates Intel x86 code to ARM so that it can run on the new Apple Silicon hardware. You can read more about the Rosetta 2 translation environment at the Apple [developer site]( gif interested.

And if the name Rosetta sounds familiar to you, it’s likely because Apple used the same name for a similar translation process when Apple moved from PowerPC (PPC) to Intel architecture, support for which was later dropped in [Lion]( Or maybe you’re familiar with the Rosetta Stone language learning software, or even the original Rosetta Stone Egyptian tablet… but anyway, for our purposes here it allows new Apple Silicon Macs to run older apps that are not yet native.

Over time, more and more Mac apps will run natively on Apple Silicon, and Rosetta 2 will eventually become unneeded, in much the same way that Rosetta for PowerPC eventually became deprecated. But that’s still years away, as Apple is just at the beginning of the process of bringing Apple Silicon to the Mac hardware lineup.

Rosetta is a translation process that allows users to run apps that contain x86_64 instructions on Apple silicon."

Install the additional command line tools that Arduino will need that play into both the xcrun error pop up and overall operation. *Note, you can ignore this but the popup will keep reappearing.

Update: Apple released the Ventura OS 13.2 after testing the past few weeks. I’m happy to report the SD card delete, empty trash, and upload issues are resolved now.

Total time to Empty Trash 53 seconds. Total time to Format SD with SD Formatter (including no longer a need to unplug the SD and plug it back in because when it was getting unmounted an error would occur) 1.57 seconds, total time to upload the same amount of fonts I usually do 2 minutes 11.68 seconds.

Just bear in mind you’ll still need Rosetta as well as the command line tools but this is good progress. The times I am seeing are now faster than before with OS Monterey or OS Big Sur.


Related topic link for reference if needed. SOME FILES ARE MISSING!..... But they're totally not

Just throwing this out here in case anyone finds it useful. With a Finder window open and selected, pressing Command-Shift-Period will toggle the visibility of hidden files.


For months I’ve been trying to remember the quick-key trick we were taught. I’m “old-school” but also like using icons and this is a quicker way to just visually see it in that mode as well as list. Thanks for the reminder.